const regex = /(?:.*?(just a simple)){3}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.*?(just a simple)){3}', '')
const str = `this is just a simple text. this is just a simple text. this is just a simple text. this is just a simple text. How are you man today. I Have been working on this.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}