# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\w)\.?\s*(?!\w\w)/$1/g;t' <<< "J R R Tolkien
E L James
F Scott Fitzgerald
JK Rowling
J.K. Rowling
J. K. Rowling
J K Rowling
"