$re = '/\b(\w)\.?\s*(?!\w\w)/';
$str = 'J R R Tolkien
E L James
F Scott Fitzgerald
JK Rowling
J.K. Rowling
J. K. Rowling
J K Rowling
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;