#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(\w)\.?\s*(?!\w\w)"
Local $sString = "J R R Tolkien" & @CRLF & _
"E L James" & @CRLF & _
"F Scott Fitzgerald" & @CRLF & _
"" & @CRLF & _
"JK Rowling" & @CRLF & _
"J.K. Rowling" & @CRLF & _
"J. K. Rowling" & @CRLF & _
"J K Rowling" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)