const regex = /^.*(?<!t|t.|tee.|polo.)\bshirts?\b/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(?<!t|t.|tee.|polo.)\\bshirts?\\b', 'mg')
const str = `Full sleeve shirt
Full sleeve casual shirt
half sleeve formal shirts
half sleeve polo-shirt
sleeveless tshirt
yellow t shirt
t.shirt
t-shirt
black full sleeve tee shirt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}