$re = '/^.*(?<!t|t.|tee.|polo.)\bshirts?\b/m';
$str = 'Full sleeve shirt
Full sleeve casual shirt
half sleeve formal shirts
half sleeve polo-shirt
sleeveless tshirt
yellow t shirt
t.shirt
t-shirt
black full sleeve tee shirt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);