re = /^.*(?<!t|t.|tee.|polo.)\bshirts?\b/m
str = 'Full sleeve shirt
Full sleeve casual shirt
half sleeve formal shirts
half sleeve polo-shirt
sleeveless tshirt
yellow t shirt
t.shirt
t-shirt
black full sleeve tee shirt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end