package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\Q&*(\E.+?\Q)(*\E`)
var str = `Bla bla bla &*( asd asd asd )(* bla bla bla. Yadda yadda yadda &*( akls lkja )(* yadda.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}