re = /\Q&*(\E.+?\Q)(*\E/
str = 'Bla bla bla &*( asd asd asd )(* bla bla bla. Yadda yadda yadda &*( akls lkja )(* yadda.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end