// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\Q&*(\E.+?\Q)(*\E").unwrap();
let string = "Bla bla bla &*( asd asd asd )(* bla bla bla. Yadda yadda yadda &*( akls lkja )(* yadda.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}