# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\+?98/0/gm;t' <<< "+989163467632
989163467632
09163467632
+989163467632"