$re = '/^\+?98/m';
$str = '+989163467632
989163467632
09163467632
+989163467632';
$subst = "0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;