import re
regex = re.compile(r"^\+?98", flags=re.MULTILINE)
test_str = ("+989163467632\n"
"989163467632\n"
"09163467632\n"
"+989163467632")
subst = "0"
result = regex.sub(subst, test_str)
if result:
print(result)