using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^""]*"")*
(^|[^a-zA-Z""])
(?P<var>A)
($|[^a-zA-Z0-9""])";
string input = @"A + B + ""to A to"" - A + XA- A500+A*""A""";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}