import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"[^\"]*\")*\n"
+ "(^|[^a-zA-Z\"])\n"
+ "(?P<var>A)\n"
+ "($|[^a-zA-Z0-9\"])";
final String string = "A + B + \"to A to\" - A + XA- A500+A*\"A\"";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}