$re = '/("[^"]*")*
(^|[^a-zA-Z"])
(?P<var>A)
($|[^a-zA-Z0-9"])/xs';
$str = 'A + B + "to A to" - A + XA- A500+A*"A"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);