$re = '/((\/\/[^\n\r]*)|(\/\*[^\*\/]*\*\/))/mi';
$str = '/* asdadasd
addds
asdasdas */
// asdasdasdasdasdas
/* asdasdasd */
asdasdasda
asdas
das
das
das
da
int counter = 0;
string line;
// Read the file and display it line by line.
System.IO.StreamReader file =
new System.IO.StreamReader("c:\\\\test.txt");
while((line = file.ReadLine()) != null)
{
Console.WriteLine (line);
counter++;
}
file.Close();
// Suspend the screen.
Console.ReadLine();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);