import re
regex = re.compile(r"((\/\/[^\n\r]*)|(\/\*[^\*\/]*\*\/))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("/* asdadasd\n"
"addds\n"
"asdasdas */\n\n"
"// asdasdasdasdasdas\n\n\n"
"/* asdasdasd */\n\n\n"
"asdasdasda\n"
"asdas\n"
"das\n"
"das\n"
"das\n"
"da\n"
"int counter = 0;\n"
"string line;\n\n"
"// Read the file and display it line by line.\n"
"System.IO.StreamReader file = \n"
" new System.IO.StreamReader(\"c:\\\\test.txt\");\n"
"while((line = file.ReadLine()) != null)\n"
"{\n"
" Console.WriteLine (line);\n"
" counter++;\n"
"}\n\n"
"file.Close();\n\n"
"// Suspend the screen.\n"
"Console.ReadLine();")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")