// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)((\/\/[^\n\r]*)|(\/\*[^\*\/]*\*\/))").unwrap();
let string = "/* asdadasd
addds
asdasdas */
// asdasdasdasdasdas
/* asdasdasd */
asdasdasda
asdas
das
das
das
da
int counter = 0;
string line;
// Read the file and display it line by line.
System.IO.StreamReader file =
new System.IO.StreamReader(\"c:\\\\test.txt\");
while((line = file.ReadLine()) != null)
{
Console.WriteLine (line);
counter++;
}
file.Close();
// Suspend the screen.
Console.ReadLine();";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}