package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(\d\s){3}\d\r\n`)
var str = `1{::HELLO:}2{:: {:: :} {:: {:: {:: {:: :} :} :} :} :}3{::HELLO:}4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}