re = /(\d\s){3}\d\r\n/mix
str = '1{::HELLO:}2{:: {:: :} {:: {:: {:: {:: :} :} :} :} :}3{::HELLO:}4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end