const regex = new RegExp('(\\d\\s){3}\\d\\r\\n', 'gmi')
const str = `1{::HELLO:}2{:: {:: :} {:: {:: {:: {:: :} :} :} :} :}3{::HELLO:}4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}