package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m): *0*([^-:]+)-`)
var str = `ABC : DEP : 050-G&H Sample - IJ
ABC : DEP : PQ-Word1 Word2 Word3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}