re = /: *0*([^-:]+)-/m
str = 'ABC : DEP : 050-G&H Sample - IJ
ABC : DEP : PQ-Word1 Word2 Word3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end