$re = '/: *0*([^-:]+)-/m';
$str = 'ABC : DEP : 050-G&H Sample - IJ
ABC : DEP : PQ-Word1 Word2 Word3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);