using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*banana.*)(?:(?!sandwich).)*ice-cream.*?sandwich.*$";
string input = @"/ice-cream/stuff/sandwich/banana
/ice-cream/stuff/sandwich/
sandwich//ice-cream/stuff/sandwich
sandwich//ice-cream/stuff/sandwich
sandwich//ice-cream/stuff/sandwich";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}