import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*banana.*)(?:(?!sandwich).)*ice-cream.*?sandwich.*$";
final String string = "/ice-cream/stuff/sandwich/banana\n"
+ "/ice-cream/stuff/sandwich/\n"
+ "sandwich//ice-cream/stuff/sandwich\n"
+ "sandwich//ice-cream/stuff/sandwich\n"
+ "sandwich//ice-cream/stuff/sandwich";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}