import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=,)\\bhttps?:\\/\\/[^,]+(?=,)";
final String string = "Something,https://stackoverflow.com/questions/ask/,Anotherthing\n"
+ "Something,https://stackoverflow.com/questions/ask,Anotherthing\n"
+ "link:https://www.google.com/something,something else\n"
+ "http://www.domain.com/without-ssl\n"
+ "Something followed by a space, https://domain.com, more to come\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}