$re = '/(?<=,)\bhttps?:\/\/[^,]+(?=,)/m';
$str = 'Something,https://stackoverflow.com/questions/ask/,Anotherthing
Something,https://stackoverflow.com/questions/ask,Anotherthing
link:https://www.google.com/something,something else
http://www.domain.com/without-ssl
Something followed by a space, https://domain.com, more to come
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);