re = /(?<=,)\bhttps?:\/\/[^,]+(?=,)/m
str = 'Something,https://stackoverflow.com/questions/ask/,Anotherthing
Something,https://stackoverflow.com/questions/ask,Anotherthing
link:https://www.google.com/something,something else
http://www.domain.com/without-ssl
Something followed by a space, https://domain.com, more to come
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end