import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^Total revenue for )\\d+[-_]?\\d+";
final String string = "Total revenue for 2016-03 is 3000 €\n"
+ "Total revenue for 2016_03 is 3000 €\n"
+ "Total revenue for 201603 is 3000 € ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}