import re
regex = re.compile(r"(?<=^Total revenue for )\d+[-_]?\d+", flags=re.MULTILINE)
test_str = ("Total revenue for 2016-03 is 3000 €\n"
"Total revenue for 2016_03 is 3000 €\n"
"Total revenue for 201603 is 3000 € ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")