const regex = new RegExp('(?<=^Total revenue for )\\d+[-_]?\\d+', 'gm')
const str = `Total revenue for 2016-03 is 3000 €
Total revenue for 2016_03 is 3000 €
Total revenue for 201603 is 3000 € `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}