#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:<p> <\/p>\s*){2,}"
Local $sString = "<myText>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p>First Text</p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p>This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...</p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p>Second Text</p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p>This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...</p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p>Third Text</p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p>This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...</p>" & @CRLF & _
" <p> </p>" & @CRLF & _
" <p> </p>" & @CRLF & _
"</myText>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")