package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:<p> <\/p>\s*){2,}`)
var str = `<myText>
<p> </p>
<p> </p>
<p>First Text</p>
<p> </p>
<p>This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...</p>
<p> </p>
<p> </p>
<p>Second Text</p>
<p> </p>
<p>This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...</p>
<p> </p>
<p> </p>
<p>Third Text</p>
<p> </p>
<p>This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...</p>
<p> </p>
<p> </p>
</myText>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}