const regex = /(?:<p> <\/p>\s*){2,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<p> <\\\/p>\\s*){2,}', 'g')
const str = `<myText>
<p> </p>
<p> </p>
<p>First Text</p>
<p> </p>
<p>This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...</p>
<p> </p>
<p> </p>
<p>Second Text</p>
<p> </p>
<p>This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...</p>
<p> </p>
<p> </p>
<p>Third Text</p>
<p> </p>
<p>This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...This is a random text we see...</p>
<p> </p>
<p> </p>
</myText>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}