use strict;
my $str = 'This should match:
ABC
ABc
AbC
Abc
aBC
abC
abc
Text with abc in it should also match. Even if it is within a word like in Barabc Obama.
This must not match:
aBc
cba
aaa
bbb
ccc
bac
ABBA';
my $regex = qr/(?![a-z][A-Z][a-z])(?i)abc/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}