re = /(?![a-z][A-Z][a-z])(?i)abc/
str = 'This should match:
ABC
ABc
AbC
Abc
aBC
abC
abc
Text with abc in it should also match. Even if it is within a word like in Barabc Obama.
This must not match:
aBc
cba
aaa
bbb
ccc
bac
ABBA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end