$re = '/(?![a-z][A-Z][a-z])(?i)abc/';
$str = 'This should match:
ABC
ABc
AbC
Abc
aBC
abC
abc
Text with abc in it should also match. Even if it is within a word like in Barabc Obama.
This must not match:
aBc
cba
aaa
bbb
ccc
bac
ABBA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);