use strict;
my $str = 'apes are super people';
my $regex = qr/p(?!e)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";