#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[.+?\]\s*"
Local $sString = "[Block 1] Thisfile.txt" & @CRLF & _
"[Block 1] Thisfile1.txt" & @CRLF & _
"[Block 1] Thisfile2.txt" & @CRLF & _
"[Backup001] Thatfile1.doc" & @CRLF & _
"[Backup001] Thatfile2.doc" & @CRLF & _
"[Backup001] Thatfile3.doc" & @CRLF & _
"[Explode] Thisplace.xls" & @CRLF & _
"[Explode] Thisplace1.xls" & @CRLF & _
"[Explode] Thisplace2.xls"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")