# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[.+?\]\s*"
test_str = ("[Block 1] Thisfile.txt\n"
"[Block 1] Thisfile1.txt\n"
"[Block 1] Thisfile2.txt\n"
"[Backup001] Thatfile1.doc\n"
"[Backup001] Thatfile2.doc\n"
"[Backup001] Thatfile3.doc\n"
"[Explode] Thisplace.xls\n"
"[Explode] Thisplace1.xls\n"
"[Explode] Thisplace2.xls")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.