import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[.+?\\]\\s*";
final String string = "[Block 1] Thisfile.txt\n"
+ "[Block 1] Thisfile1.txt\n"
+ "[Block 1] Thisfile2.txt\n"
+ "[Backup001] Thatfile1.doc\n"
+ "[Backup001] Thatfile2.doc\n"
+ "[Backup001] Thatfile3.doc\n"
+ "[Explode] Thisplace.xls\n"
+ "[Explode] Thisplace1.xls\n"
+ "[Explode] Thisplace2.xls";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}