using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?:[^)(]|\([^)(]*\))*\)";
string input = @"stuff (remove(me)) stuff ((bar)remove(me)) stuff (a) (a(b))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}