re = /\((?:[^)(]|\([^)(]*\))*\)/
str = 'stuff (remove(me)) stuff ((bar)remove(me)) stuff (a) (a(b))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end