package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?:[^)(]|\([^)(]*\))*\)`)
var str = `stuff (remove(me)) stuff ((bar)remove(me)) stuff (a) (a(b))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}