using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*window\.).*\b(console\.log|alert\().*$";
string input = @"console.log(""dddsdsf"");
alert(""dasassd"");
window.alert(""asdasasasd"");";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}