re = /^(?!.*window\.).*\b(console\.log|alert\().*$/m
str = 'console.log("dddsdsf");
alert("dasassd");
window.alert("asdasasasd");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end