import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[ ]{4,}|\\t{1,})(.+)";
final String string = "This is a code block:\n\n"
+ " There are four spaces\n"
+ " before each line\n"
+ " testing\n\n"
+ "How about a code fence?\n\n"
+ "``` xojo\n"
+ "This must have three backticks\n"
+ "flanking it\n"
+ "```\n\n"
+ "I love `inline code` too\n\n"
+ "and more code blocks:\n\n"
+ " Don't you?\n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}