$re = '/(?:[ ]{4,}|\t{1,})(.+)/m';
$str = 'This is a code block:
There are four spaces
before each line
testing
How about a code fence?
``` xojo
This must have three backticks
flanking it
```
I love `inline code` too
and more code blocks:
Don\'t you?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);